Centova Technologies Inc.

Products and Services

Centova Cast
Customer Support
Centova Technologies
 

Centova Technologies Forum

Author Topic: With EC2 CC is using the private IP address  (Read 317 times)

trumpetradio

  • Newbie
  • *
  • Posts: 7
With EC2 CC is using the private IP address
« on: March 06, 2018, 09:59:50 am »
Ok, I have CC installed on an AWS EC2 instance. For the most part all is working fine. But, I have one situation I cannot resolve.

AWS EC2 are assigned both a public and private IP address. For some reason CC is using the private IP address. Everywhere in the settings and Quick Links it is using the private IP address, which is not accessible from the Internet.

I have tried changing this from the "Host Manager" screen, and it changes and all new accounts after that show the correct IP, but then they will not start. When trying to start the stream I get an error, of which I have included a screenshot. The only way to get the streams to start is to change the IP back to the private IP address.

I know I can set CC to use the hostname in all emails and such instead of the IP, and that customers can just use that for their hostname for their source. But, if they login and go to settings it shows the private IP and I've had some try to use that, which won't work, and then they get confused.

Can you tell me how to get CC to use the public IP instead of the private IP of my EC2 server?

For the record, I have CentovCast v3.2.10 installed on Ubuntu 16.0.4 LTS. I know that Ubuntu is not officially supported, but it seems to work just fine.


« Last Edit: March 06, 2018, 10:05:23 am by trumpetradio »

Alexiu

  • Centova Staff
  • *
  • Posts: 480
Re: With EC2 CC is using the private IP address
« Reply #1 on: April 05, 2018, 11:30:18 am »
You should be able to work around this by setting up your streams to use your LAN IP and then using the SELFREF_OVERRIDE setting to set all links (in playlists/tune-in links/etc) to point to your WAN IP address.